Blocking the VAC system (1 Viewer)

Status
Not open for further replies.

EvoWarrior5

Well-Known Member
Contributor
Joined
Aug 14, 2013
Messages
2,616
Reactions
2,493
Steam
#1
I've been having the issue all day that I can't join any servers because an issue with my computer is blocking the VAC system. The web page (https://support.steampowered.com/kb_article.php?ref=2117-ILZV-2837) says that custom files can cause it, but I haven't downloaded any game-modifying stuff in ages (besides new jump maps, which really shouldn't be the problem).

I really don't want to uninstall the game and lose my current settings. Does anyone have a potential solution? I've already verified my game files, didn't help.
 

Stabbin

Gameserver Admin
Staff member
Gameserver Admin
Donator
Development
Joined
Aug 6, 2013
Messages
711
Reactions
1,229
Steam
#2
backup your cfg folder and reinstall :D?
 

EvoWarrior5

Well-Known Member
Contributor
Joined
Aug 14, 2013
Messages
2,616
Reactions
2,493
Steam
#3
backup your cfg folder and reinstall :D?
I have more than just my cfg folder though lol, also several jump maps I downloaded over time. Plus I've been confused for a long time about where config-related files actually go, there were like 3-4 different options I had to try before my configs worked decently. So I have several files scattered across folders with no idea which ones do what to get the settings I have. Dunno why it is so complicated, but that happened.
 

fanthom

Gameserver Admin
Staff member
Gameserver Admin
Joined
Jun 26, 2016
Messages
1,153
Reactions
1,103
Steam
#5
Dont know if you are running any Idling Programms in the background but it causes the same effect from time to time.
 

Zeprus

Gameserver Admin
Staff member
Gameserver Admin
Joined
Jan 2, 2015
Messages
941
Reactions
1,226
Steam
#6
Otherwise firewall settings, any security updates, antivirus updates are all possible reasons for it so you might check those.

This thread has a bunch of stuff you can try as well.
Otherwise I would try what stabbin said, backup your cfg/download/custom folders and reinstall. All of these folders are located in your steam/steamapps/common/Team Fortress 2 directory.
 

EvoWarrior5

Well-Known Member
Contributor
Joined
Aug 14, 2013
Messages
2,616
Reactions
2,493
Steam
#7
I fixed it, I added my Steam folder to antivirus exceptions and deleted my appcache folder before restarting my PC. Not sure which of those did the trick, but something helped.
 

Stabbin

Gameserver Admin
Staff member
Gameserver Admin
Donator
Development
Joined
Aug 6, 2013
Messages
711
Reactions
1,229
Steam
#8
I added my Steam folder to antivirus exceptions
Bad idea, I suggest checking if this wasn't what was causing it and if not remove the exception. You download numerous of files when you connect to servers, there have been many source engine related exploits found that utilize the downloading of custom files. You should at least remove /downloads from the exceptions.
 
Status
Not open for further replies.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)